All systems operational

Disruption RZ - Mail / Antispam

Resolved
Partial outage
Started about 1 month ago Lasted 39 minutes

Affected

Kommunikation
Hosted Exchange
Premium Antispam
Updates
  • Resolved
    Resolved

    The problem was resolved and the service is now fully available again. All pending emails were sent successfully. No emails were lost.

  • Identified
    Identified

    Due to a disruption in email communication, the service is currently only available to a limited extent.